Jump to content
Sevriss

Battle controls bug

Recommended Posts

 Hi,
I will try to be as clear as possible, English is not my native language.
First: I am on PC, win 10, 16G DDR4 gskill, MSI geforce GTX 1070 X.

The bug itself: It happens in battle, the selection of squadrons or weapons is not done. So we can't order shooting, movement, or attacks. This is sometimes resolved by deselecting the squadron or weapon and then re-selecting them.  This does not always work, and results in a consequent loss of time in battle and often to be exploded by the enemy.
I specify that this happens without critical damage on the ship, and with a sufficient number of action points, there is nothing a priori that should prevent selecting the weapons or squadrons.

Good luck to the devs with that, this beta looks very nice anyway.

 

output_log.rar

Share this post


Link to post
Share on other sites

I had the same issue. I started the battled with no squadron in the 'slots' (I had 2 slots at the time)

I selected Fighters but wasn't allowed to select their spot on the field. They did show up on the bottom left spot but I couldn't move them to other spots. 

Same with the Cruisers that came out right after, (1 spot above the Fighters) I could only have them return to the ship by right clicking their icon in the Squadron selection boxes.

Tried to have them come out regular after that but nothing changed. 

 

*I play on Windows 10, Intel i3-7100, 8 GB Ram and Intel HD Graphics 630*

 

output_log.txt

Edited by Tim

Share this post


Link to post
Share on other sites

Hello and thanks for your bug report ! 

Does this selection issue happens all the time, in every fight? or does it happens randomly/only  at a certain point in the game?

We'll try to reproduce this and keep you updated about this issue

Share this post


Link to post
Share on other sites

I have only had it once so far. I do believe that was the only time I didn't have a squad lined up in the selection slot when the battle started

Edited by Tim

Share this post


Link to post
Share on other sites

I've had this problem on different fights, irregularly. As said above, sometimes, by putting away a squadron or a weapon, they would work again after a while, to bug again after. Pretty mysterious. I plan to play again tomorrow to see if this is systematic.

 

J'ai eu ce problème sur différents combats, de façon irrégulière. Comme dit plus haut, parfois, en rangeant un escadron ou une arme, ceux ci remarchaient après pendant un certain temps, pour re-buguer après. Assez mystérieux. Je compte refaire des parties demain pour voir si ceci est systématique.

Share this post


Link to post
Share on other sites

Strangely, no more control problems on 4 tries. I had the opportunity to play a little bit, and it doesn't happend again.

Share this post


Link to post
Share on other sites

Hello,

We managed to reproduce it, it requires a strange succession of actions to trigger. Thanks to your feedbacks I think we will be able to release a fix on monday or tuesday ?

  • Like 2

Share this post


Link to post
Share on other sites

Hello there,

This bug is (normally) fixed in the new version of the Beta. You can download it now by using the same URL as you used to download the previous version.

More information about the bug fixed here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×